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ECDL Image Editing 

 

This ECDL Image Editing module enables you to understand the main concepts underlying digital 

images and how to use image editing software. You will learn how to enhance images, apply 

effects, and prepare an image for printing and publishing.  

 

On completion of this module you will be able to: 

 Understand the main concepts of using digital images; understand graphic format options 

and colour concepts.  

 Open an existing image; save an image in different formats; set image file options. 

 Use built-in options, such as displaying toolbars, palettes, too enhance productivity.  

 Capture and save an image; use various selection tools; manipulate images.  

 Create and use layers; work with text; use effects and filters; use drawing and painting tools.  

 Prepare images for printing or publishing.  

 

What are the benefits of this module? 

This module provides a solid grounding in working with digital images, and gives you the platform to 

develop your skills in this area in the future. Once you have developed the skills and knowledge set 

out in this book, you will be in a position to become certified in an international standard in this area 

– ECDL Image Editing. 
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LESSON 1 - 

IMAGING CONCEPTS 

 

In this section, you will learn how to: 
 

 Identify common uses of digital images 

 Understand pixel, resolution and file size 

 Identify key features of a digital image 

 Comparing lossy and lossless image compression 

 Understand copyright and  the implication of use 
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1.1 COMMON USES OF DIGITAL IMAGES 

 
Digital images are an increasingly important and common type of digital content 
both for workers and for home users. 
 
Common uses of digital images include: 

 

 

 Web and print publishing - Publish images to websites, social networks or 
photo sharing sites, or use image for print publishing, for example in 
magazines or brochures.  
 

 Distribution by e-mail and mobile phone - Send your images to friends or 
colleagues 

 

 Home printing - Use a printer to print at home  
 

 Digital photo frames - Display images on a digital photo frame 
 
 

1.2 DIGITAL IMAGES AND PIXELS  

 
A digital image is a representation of an image in numeric (generally binary) form. 
Digital images are composed of discrete pixels. The word pixel is derived from the 
words picture and element. Pixels are the smallest part of a digital image on a 
screen or a single point in a picture.  
 
 
Resolution 
 
The term resolution refers to the detail and quality of an image, and in a digital 
images resolution is often determined by pixel dimensions, or the number of pixels 
along the width and height of an image 
 
 
File Size and Compression 
 
The digital size of an image is measured in kilobytes (K), megabytes (MB), or 
gigabytes (GB). File size is related to the pixel dimensions of the image. Images 
with more pixels may produce more detail at a given printed size, but they require 
more disk space to store and may be slower to edit and print. 
 
Image resolution is therefore a compromise between image quality and file size. 
 
File format can also affect file size - due to varying compression methods used by 
GIF, JPEG, and PNG file formats, file sizes can vary considerably for the same 
pixel dimensions.  
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Some file formats, such as JPEG, use lossy compression. Lossy compression 
creates a smaller sized compressed file that results in a lower resolution picture 
with pixel loss. 
 
Other file formats, such as PNG, use lossless compression. Lossless 
compression ensures that the compressed data can be reconstructed to the 
exact original image without pixel loss.  

  

1.3 COPYRIGHT 

 
Copyright is protection for intellectual property. Intellectual property consists of 
anything an individual has written or created, including music, text, pictures, 
photographs, sounds. Specifically, copyright specifies the rights granted to use, 
publish, or distribute images or other pieces of work for a specific time period. 
 
It is important to note that you cannot use intellectual property – for an example, 
an image that you find on the web – without considering the copyright protection 
associated with the image. It may be possible to acquire rights to an image 
through a licensing arrangement.  

 

 
Common License Models for Images 
 
There are several common licenses or business models governing the use of the 
images: two of the most common are royalty-free images and rights-managed 
images. 
 
 

1. Royalty-free images 
 

 Under this arrangement, you incur a one-off fee allowing you to use the 
image as many times as required with some restrictions.  
 

2. Rights-managed images 
 

 Under this arrangement, images have a copyright license which, if 
purchased by a user, allows the one time use of the photo as set out by 
the license. 
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1.4 REVIEW EXERCISE 

 
1. What is the term used to describe the smallest part of a digital image? 

 
 

 
2. List 2 examples of materials that may be protected under the copyright law:  

 
 
 

3. Give an example of a lossy file format? 
 
 
 

4. Under what licensing arrangement can you pay a one-off fee and use an image 
several times? 

 
 



LESSON 2 – 

GRAPHIC FORMATS 

 

In this section, you will learn how to: 
 

 Distinguish raster and vector images 

 Identify common raster formats 

 Identify common vector formats 

 Recognise proprietary digital image editing application formats 
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2.1 RASTER AND VECTOR IMAGES 

 

 
 

Raster Images 
 
Raster images, sometime referred to as bitmap images, use a rectangular grid of 
picture elements (pixels) to represent images. Each pixel has a specific location 
and colour value. When you work with a raster image, you edit pixels rather than 
objects or shapes.  
 
Raster images contain a fixed number of pixels, and they cannot be scaled to a 
large size without losing quality.  
 
Specific file formats support raster images 
 

Raster File Format File Extension 

Joint Photographic Experts Group (JPEG) .jpeg 

Graphics Interchange Format (GIF) .gif 

 
JPEG 
 

 The JPEG format is commonly used to display photographs and other 
continuous-tone images on the Web. 

 

 It does not support transparency. 
 

 Unlike GIF format, JPEG retains all colour information in an RGB image 
but compresses file size by selectively discarding data. JPEG images are 
automatically decompressed when they are opened. 

 
GIF 
 

 On The GIF file format commonly used to display indexed-colour graphics 
and images on the Web.  
 

 GIF is a compressed format designed to minimise file size and electronic 
transfer time. 
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 It supports transparency and is particularly useful for images such as 
graphics and logos.  

 
 
Vector Images 
 
In contrast, vector images consist of lines and curves defined by mathematical 
objects called vectors. These define the image according to it geometric 
characteristics. 
 
Vector images can be modified without losing detail or clarity, as they are 
independent of resolution. 
 
Specific file formats support raster images.  
 

Raster File Format File Extension 

Scalable Vector Graphics (SVG) .svg 

Encapsulated PostScript (EPS) .eps 

 
SVG 
 

 SVG is an open standard created and developed by the World Wide Web 
Consortium. 
 

 It provides a versatile, scriptable and all-purpose vector format. 
 

 SVG files can be compressed using lossless data compression 
techniques. 

 
EPS 
 

 EPS is a standard graphics file format for exchanging images, drawings, or 
layouts of complete pages. 
 

 The file internally contains a description of such an object or layout using 
the PostScript language.  

 
 

2.2 PROPRIETARY APPLICATION FORMATS 

 
A native file format is the default file format used by a specific software 
application. The native file format of an application is proprietary, and these types 
of files are generally not meant to be used with other applications. 
 
Usually special software-specific image properties – for example, editable layer 
styles and text - can only be preserved when an image is saved in the software's 
native format.  
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The following table shows the proprietary image file format for some of common 
image editing applications: 
 

Image Editing Application Native File Format 

GIMP 
.xcf 

 

Adobe Photoshop 
.psd 

 

Paint Shop Pro 
.psp 

 

Adobe Illustrator 
.ai 

 

Corel Photo Paint 
.cpt 

 



 

LESSON 3 - 

COLOUR CONCEPTS 

 

In this section, you will learn how to: 
 

 Understand the term colour model 

 Recognise common colour models 

 Understand colour palette and depth 

 Understand colour terms 

  



Lesson 3 – Colour Concepts  ICDL Image Editing 

Page 10   © 2016 

3.1 COLOUR MODELS 

 

A colour model is a mathematical model that describes how colours can be 
represented as lists of numbers, typically as three or four values or colour 
components. Different colour models can be used depending on the medium, for 
example, print or web, being used.  
 
The four most common colour models are RGB, CMYK, HSB, and greyscale. 

   

RGB  
 
The RGB colour model combines red, green and blue colours. In this model, an 
intensity value is assigned to each pixel. Usually, the intensity values range from 0 
(black) to 255 (white) for each of the RGB (red, green, blue) components in a 
colour image.  
 
Although RGB is a standard colour model, the exact range of colours represented 
can vary, depending on the application or display device  
 
 
CMYK  
 
In the CMYK mode, each pixel is assigned a percentage value for each of the 
process inks (usually, cyan, magenta, yellow and key, or black). The lightest 
(highlight) colours are assigned small percentages of process ink colours, 
whereas the darker (shadow) colours higher percentages.  
 
You should use the CMYK mode when preparing an image to be printed using 
process colours. 
 
HSB 
HSB stands for Hue, Saturation and Brightness. This model describes a colour 
using three numbers.  
 

 The first number is the hue, and its value ranges from 0 to 360 degrees. 
Each degree represents a distinct colour.  

 

 The second number is the saturation. It represents the amount of colour or, 
more exactly, its percentage. Its value ranges from 0 to 100, where 0 
represents no colour, while 100 represents the full colour. 

 

 The third number is the brightness. You can enhance the colour brightness 
adding the white colour, or we can reduce it adding the black colour. In this 
case 0 represents the white colour and 100 represents the black colour 

 
 
Greyscale 
 
Images in this colour model – which is also referred to as black-and-white - are 
composed exclusively of shades of gray, varying from black at the weakest 
intensity to white at the strongest. 
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3.2 COLOUR PALETTE AND DEPTH 

 
A colour palette is the finite set of colours available for digital images. For 
example, a common palette used in computers is a 256-colour palette. The 
palette used may be limited by hardware limitations, for example the specification 
of a monitor.  
 
Colour depth is the maximum number of colours that are used in an image: The 
higher the depth, the broader the range of distinct colours and the more realistic 
the image is. Colour depth is related to the number of bits (units of digital 
information) used for each colour component of an individual pixel. For example, 
True Color (24-bit) supports high quality images and complex graphics.  

 
 

3.3 UNDERSTANDING COMMON COLOUR TERMS 

 
Other important terms relating to digital images include: 
 

 

 Hue - A pure colour described by name, such as “red” or “yellow” 
 

 Saturation - The dominance, or intensity, of hue in the colour 
 

 Colour balance - The overall adjustment of the intensities of the colour 
 

 Contrast - The difference in colour and light level in an image 
 

 Brightness - The degree to which an image radiates light 
 

 Gamma - The way brightness is changed for the middle range of gray tones 
 

 Transparency - The ability of light to transmit through an image 
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3.4 REVIEW EXERCISE 

 
1. Define the following terms: 

 
a. Hue 

 
b. Saturation 

 
 

2. Name the 2 colour models. 
 
 

 
3. Give an example of a common colour palette. 

 
 
 



LESSON 4 – 

CAPTURING IMAGES 

 

In this section, you will learn about: 
 

 Saving Images from Digital Camera 

 Using Print Screen Facility 

 Saving Image from Image Library 

 Scanning Images 
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4.1 SAVING IMAGES FROM A DIGITAL CAMERA 

 
Before you start working with digital images on a computer, you need to acquire 
the images and move them to the computer. A common source of digital images is 
a digital camera.  
 
To copy images from a media source such as a memory card or directly from a 
camera, follow these steps: 
 

1. Connect the media to the computer using one of the methods below: 
 

 Connect the camera to computer using the USB cable and switch 
on the camera to the transfer mode or 
 

 Insert the media card into our computer card reader slot. 
 

2. On your computer, double click on the drive that represents the camera or 
media card. 
 

3. Open the folder containing the images. 
 

4. Select the required images or the entire folder. 
 

5. Drag them to a folder on our hard drive to copy them to our computer. 
 

 
 

 

 

4.2 USING THE PRINT SCREEN FACILITY 

 
You can also create an image by capturing the current screen or active window on 
your computer using the Print Screen facility. 

 
To capture screen shot: 
 

1. Activate the screen to window required. 
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2. Press the Print Screen (to capture the current screen) or ALT Print 
Screen (to capture the active window only) on our keyboard.  
 

3. Open an image editing program.  
 

4. Choose Edit > Paste.  
 
When working with a laptop/notebook PC, the print screen key may share the key 
with another command. In this case, press Function or Fn and the key for the 
print screen at the same time. 
 

 
Print Screen 

 

 
ALT + Print Screen 

 

4.3 SAVING IMAGE FROM IMAGE LIBRARY 

 
To save image from an online source, such as an online image library: 
 

1. Right-click the image. 
 

2. On the shortcut menu that appears, select Save Picture As… 
 

3. In the Save In list box, select a location. 



Lesson 4 – Capturing Images  ICDL Image Editing 

Page 16   © 2016 

 
4. Click Save to save the image. 

 
The saved image can then be opened in an image editing application. 
 
Most online image libraries are subscription based for user-generated, royalty-free 
stock photos and illustrations. 
 
Popular image library sites include www.istockphoto.com and 
www.shutterstock.com 
 

4.4 SCANNING IMAGES 

 
Another method of acquiring images is by scanning documents, images or 
objects. Scanning creates a digital image that can then be manipulated using 
image editing software. The most common type of scanner is a desktop flat-bed 
scanner.  

 
The process of scanning an image involves: 
 

 
1. Place the image on the scanner.  
 
2. Click Scan to view options. 
 
3. Follow the instructions to choose the scanning parameters. These 

typically include resolution (which will directly influence the quality of the 
image) and file format. 

 
4. Navigate to the location required to save the image. 
 
5. Click Scan 

 
 

 
 

  

http://www.istockphoto.com/
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4.5 REVIEW EXERCISE 

 
1. Search for the following images online and save them using an appropriate file 

name. 
 
a. The Taj Mahal 

 
 

b. A Lightning Storm 
 
 
 

2. Name two common scanning parameters? 
 
 
 
 

3. What is the keyboard shortcut used to capture the current active window? 
 
 
 



 

LESSON 5 - 

CREATING IMAGES 

 

In this section, you will learn about: 
 

 Familiarization of GIMP interface 

 Opening and placing image files 

 Switching between open image files 

 Creating new image file 

 Saving images 
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5.1 GIMP INTERFACE AND CREATING IMAGES 

 
GIMP is the GNU Image Manipulation Program. It is a freely distributed software 
for such tasks as photo retouching, image composition and image authoring. It 
works on many operating systems, in many languages. 
 
GIMP’s environment contains a set of well-defined tools and dialog boxes that are 
easily accessible and customizable. It supports a large number of image formats 
and high-end graphics for different media. 
 
We would need to familiarise ourselves with design creation and image editing 
techniques using this software. Understanding the different tools and features 
available in GIMP will help us maximise our creative potential. 
 
 
Familiarization of GIMP Interface 
 
GIMP has a user friendly-interface with a variety of tools and features to help us 
design, create, and enhance images, and produce professional designs for both 
print and web. 
 
By default, the screen consists of the following: 
 

 Menu bar 
 

 Toolbox 
 

 Image window 
 

 Dialogs 
 

 Status bar. 
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Interface 
Element 

Description 

 
Menu bar Consists image editing and enhancement 

commands. 

 
Toolbox Displays available tools. 

 
Tool options Appears below the toolbox and displays additional 

options for the currently selected tool. 

 
Image window Displays the current image file opened in GIMP. We 

can view, create, or edit images here. 

 
Dialogs Comprises of dialogs with a tab for each dialog. Most 

of the dialogs contain a menu, which allows us to 
perform additional tasks. Some of the dialogs are 
CHANNELS, PATHS, LAYERS, and UNDO 
HISTORY. 

 
Status bar Appears at the bottom of the screen, and displays the 

unit of measurement and current magnification of the 
image.  
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The Menu Bar 
 
The Menu bar is located at the top of the screen. 
 

  
 
The bar's main purpose is to give us a central location for the software's 
commands, tools and options rather than having them scattered throughout 
GIMP. For example, the first menu File, contains all file related commands such 
as open, save, export and print. 
 
 
Tools Panel 

 
Along the left side of the screen is GIMP's Toolbox. This is where we find all of 
the various tools we need for working on our images. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Pointing to a tool displays the tool's name and the shortcut key if available. 
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Toolbox Overview 
 
Tool Name    Shortcut Key 

 Rectangle Select  R 

 Ellipse Select   E 

 Free Select   F 

 Fuzzy Select   U 

 Select By Color  SHIFT O 

 Scissor Select I 

 Foreground Select 

 Paths B 
 
Tool Name    Shortcut Key 

 Color Picker   O 

 Zoom    Z 

 Measure   SHIFT M 

 Move    M 

 Alignment   Q 

 Crop    SHIFT C 

 Rotate    SHIFT R 

 Scale    SHIFT T 

 Shear    SHIFT S 

 Perspective   SHIFT P 

 Flip    SHIFT F 

 Cage Transform  SHIFT G 

 Text    T 

 Bucket Fill   SHIFT B 

 Blend    L 

 Pencil    N 

 Paintbrush   P 

 Eraser    SHIFT E 

 Airbrush   A 

 Ink    K 

 Clone    C 

 Healing   H 

 Perspective Clone 

 Blur / Sharpen  SHIFT U 
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 Smudge   S 

 Dodge / Burn   SHIFT D 

 Foreground & background colors 

 Swap colors 

 Reset colors 
 
 

 
The Tools Options Panel 
 
Directly related to the Toolbox is the Tool Options panel at the bottom of the 
Toolbox. It always changes to display the relevant settings and options for 
controlling whichever tool we have currently selected. 
 
Here, the Tool Options panel is displaying options for the Foreground Select 
tool. 
 

 
 

 
The Dialogs 
 
To the right of the image window, there is another panel containing dialogs for 
manipulating image layers, colour channels and Undo History. Each of these 
dialogs is organised as a tab in the panel and can be displayed by clicking on the 
tab heading of the dialog. Dialogs are the most common means of setting options 
and controls in GIMP. 
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GIMP has three default docks:  
 

1. The Tool options dock under the Toolbox in the left panel. 
 

2. The Layers, Channels, Paths and Undo dock in the upper part of the 
right panel. 
 

3. The Brushes, Patterns and Gradients dock in the lower part of the right 
panel. 

 
In these docks, each dialog is in its own tab. 
 
 
In multi-window mode, the Toolbox is a utility window and not a dock. In single-
window mode, it belongs to the single window.  
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Use Windows > Dockable Dialogs to view a list of dockable dialogs. Select a 
dockable dialog from the list to view the dialog. If the dialog is available in a dock, 
then it is made visible.  
 

 
 
 

5.2 OPENING, PLACING AND CLOSING IMAGE FILES 

 
Opening the Application 
 

 Click the Start button. 
 

 Select All Programs. 
 

 Click GIMP. 
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Opening Files 
 

 We can open files using the File > Open command and File > Open 
Recent command. 
 

 We can also open files into GIMP by dragging and dropping the file into 
the image window.  
 
Closing Files 
 

 We can close a single file using the File > Close command. 
 

 We can close multiple open files using File > Close All command. 
 
Exiting the Application 
 
When done with the application, choose File > Quit or press CTRL Q to close the 
application. 
 
 

5.3 SWITCHING BETWEEN OPEN FILES 

 
When opening multiple images in GIMP, only one image is visible at a time, but if 
we look above the image, we see a series of tabs, with each tab containing the 
thumbnail of one of the images. The tab of the image that's currently visible is 
highlighted. 
 

 
 
To switch to a different image, simply click on another image's tab, similar to how 
we switch between GIMP's dialog on the right of the screen by clicking on their 
tabs. 
 
If we have so many images open at once that GIMP cannot fit all of their 
thumbnail tabs on the screen, we will see arrow icon appear at both ends of the 
tabs. Clicking on the icon scrolls the tabs allowing us to select any of the images. 
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5.4 CREATING NEW IMAGE FILE 

 
The Create a New Image dialog box is displayed every time we create a new 
design document by choosing File > New.  
 
We can do the following in the new dialog box: 
 

 Choose a template, or specify the width, height, and resolution. 
 

 Select the image's colour space. 
 

 Specify the colour of the background contents. 
 

 
 

 
Templates 
 
GIMP has created a selection of templates for us to choose from when creating 
images. These templates are nicely arranged into a sequence of categories based 
on different workflows. 
 
The Template drop-down menu includes the following options: 
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Width and Height 
 
The width and height entered here will determine how wide and tall the image will 
be. This and resolution are the most important of all information within this dialog 
box. This is because the size of the image cannot be changed without causing 
noticeable damage to the image's appearance. 
 
The width and height can be set using various measurement units. 
 

 
 
 
Resolution 
 
Resolution is the next consideration when creating a new image. It depends on 
the output that we are targeting. 
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Colour Space 
 
The Colour space drop down allows us to select a colour space to work in. The 
RGB colour space is preferred for most image editing and manipulation in GIMP. 
Because RGB has a 24-bit colour depth, a wide variety of filters and other 
manipulation tools can be applied to the image. Working with a lesser colour 
depth (or mode) will make some of these filters and tools unavailable. 
 

 
 

 
Background Fill 
 
The Fill with option assigns a background colour or transparency to our image. 
The options are:  
 

 Foreground Colour 
Creates an image using the foreground colour displayed in the Toolbox. 
The foreground colour is the one on the right of the two colour swatches. 
 

 Background Colour 
Creates an image using the background colour displayed in the Toolbox. 
The background colour is the one on the right of the two colour swatches. 
 

 Transparency 
Creates an image without any colour. Transparency is displayed with a 
grey check pattern by default. 
 

 White 
Creates an image with a white background. 

 

 
 

 
Image Window 
 
The top and bottom bars of an image window contain useful information about the 
image. The top of the image window, called the title bar, displays the image name, 
the working colour space, number of layers, and the dimension.  
 

 
 
The bottom of the image window is called the status bar. The first field on the left 
is the drop down list to choose the measurement unit, followed by the current 
image magnification. Next, current layer and file size is displayed. 
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Create New Image from Clipboard 
 
To create a new image based on clipboard: 
 

1. On the desired application (for example, Internet browser) press Print 
Screen. 
 

2. In GIMP, choose Edit > Paste as > New Image. 
 
A new image file is created with the current image in the clipboard. The Layer 
dialog shows a new layer named as Pasted Layer. 
 

 
 
 

5.5 SAVING IMAGES 

 
Once we design our artwork and finalise it, we may want to convert it to other file 
formats for diverse distribution. While saving images in another format, it is best to 
have 3 versions of it. 
 

 A copy of the source file before making any changes to it. 
 

 A copy of the file as a GIMP file (.xcf). 
 

 The file as it is saved in the desired format. 
 
Save an image to a location on a drive. 
 

1. On the File menu, click Save. 

2. Create a file name and navigate to the required location. 

3. Click Save. 

Save an image under another name to a location on a drive. 
 

1. On the File menu, click Save As. 

2. Enter a new file name over the existing file name and navigate to the 

location required. 
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3. Click Save. 

 

 
Saving Images for Print 
 
Files for print are typically saved in TIFF or JPEG file formats. Monitor displays 
images using light, while a printer reproduces images using inks and pigments. As 
a result, the printed copy can appear quite different with the screen version. 
 
To save a file for print: 
 

1. Open the file in GIMP. 
 

2. Choose File > Export. 
 

3. In the Export Image dialog box, click on the Select File Type (By 
Extension) expand icon. 
 

4. Select JPEG image or TIFF image. 
 

5. Enter a filename. 
 

6. Click Export. 
 

7. Specify the required export image options. 
 

8. Click Export. 
 

 
Saving Images for the Web 
 
Web graphics are commonly saved in either JPEG or GIF formats. JPEG images 
can contain millions of colours and shades, so it is the preferred format for 
photographs. 
 
To save images for the web in GIF format: 
 

1. Choose File > Export. 
 

2. Enter a file name in the Name box. 
 

3. In the Export Image dialog box, click on the Select File Type (By 
Extension) expand icon. 
 

4. Select GIF image. 
 

5. Click Export. 
 

6. Specify the required GIF Options. 
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7. Click Export. 
 
 
PNG (Portable Network Graphics) was created as an improved replacement for 
GIF that supports lossless image compression. 
 
To save images in PNG format: 
 

1. Choose File > Export. 
 

2. Enter a file name in the Name box. 
 

3. In the Export Image dialog box, click on the Select File Type (By 
Extension) expand icon. 
 

4. Select PNG image. 
 

5. Click Export. 
 

6. Specify the required options in the Export Image as PNG dialog box. 
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7. Click Export. 
 
 



LESSON 6 – 

LAYOUT SETTINGS 

 

In this section, you will learn about: 
 

 Choosing foreground and background colours 

 Setting grid properties 
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6.1 FOREGROUND AND BACKGROUND COLOURS 

 
GIMP uses the foreground colour to paint, fill, and stroke selections and the 
background colour to make gradient fills and fill in the erased areas of an image. 
The foreground and background colours are also used by some special effects 
filters. 
 
We can designate a new foreground or background colour using the Color Picker 
tool, the FG/BG Color dialog, the Palette Editor dialog, or the Color Selection 
dialog.  
 

 
 
The default foreground colour is black, and the default background colour is white.  
 

 
 
 
Color Selection Dialog 
 
The Color Selection dialog is a tool used for choosing colours. These colours can 
then be used for painting, filling areas with colour, and a whole bunch of other 
things. 
 
The colour in the Color Selection dialog displays the colour components in HSB 
(HSV) colour mode, RGB colour mode, and HTML notation. If we know the 
numeric value of the colour we want, we can enter it into the text fields. We can 
also use the colour slider and the colour field to preview a colour to choose. As we 
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adjust the colour using the colour field and colour slider, the numeric values are 
adjusted accordingly. 
 

 
 

6.2 SETTING GRID PROPERTIES 

 
The grid is useful for laying out elements symmetrically. The grid appears by 
default as nonprinting lines but can also be displayed as dots. 
 
To display the grid, choose View > Show Grid. 
 
To do set the grid properties, do the following: 
 

1. Choose Edit > Preferences > Default Grid. 

 



ICDL Image Editing   Lesson 6 – Layout Settings 

© 2016   Page 37 

 
2. For Appearance, select a display option for the grid. 
a. Choose a Line Style from the drop down list provided. 
b. Set a Foreground colour (grid colour). 
c. Set a Background colour. 

 
3. Set the Spacing and Offset options. 
a. Spacing: Select the cell size of the grid and the unit of measurement. 

Click the Link icon  to change the horizontal (Width) and vertical 
(Height) spacing individually. 

b. Offset: Set the offset of the first cell. The coordinate origin is the upper left 
corner of the image. By default, the grid begins at the coordinate origin, 
(0,0). 
 

4. Click OK. 
 
 
 

  



Lesson 6 – Layout Settings  ICDL Image Editing 

Page 38   © 2016 

6.3 REVIEW EXERCISE 

 
1. Open the image Wheel Template. 

 
2. Use the Color Selection dialog to mix the colours. 

 
The different colours in the colour wheel are made up of three primary colours: 
red, green and blue; three secondary colours: cyan, magenta and yellow and six 
tertiary colours that fall in between each of the primary and secondary colour 
values. 
 
Use the Bucket Fill tool to apply the colours to the wheel. 
 

3. Use the following RGB values: 
 

Colour Group Hue R G B 
Primary colour 
(RGB) circles 

Red 255 0 0 
Green 0 255 0 
Blue 0 0 255 

 
Secondary colour 
circles 

Cyan 0 255 255 
Magenta 255 0 255 
Yellow 255 255 0 

 
Tertiary colours 
circles 

Orange 255 127 0 
Yellow 
green 

127 255 0 

Cyan 
green 

0 255 127 

Cyan 
blue 

0 127 255 

Purple 127 0 255 
Pink 255 0 127 

 
4. Save the file as Colour Wheel. 



 

LESSON 7 –  

ENHANCING PRODUCTIVITY 

 

In this section, you will learn about: 
 

 Setting basic options and preferences 

 Using the Help function 

 Using magnification and zoom tools 

 Performing undo or redo with History panel 

 Manipulating toolbars, panels and windows 
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7.1 SETTING BASIC OPTIONS AND PREFERENCES 

 
Main Window 
 
The GIMP user interface is available in two modes: multi-window mode and single 
window mode. When we open GIMP for the first time, it opens in multi-window 
mode by default. We can enable single-window mode through Windows > 
Single-Window Mode.  
 
 
Setting Preferences 
 
Numerous program settings such as general display options, file-saving options, 
and performance options are set in the Preferences dialog box. The preferences 
dialog can be accessed Edit > Preferences. It lets us customise many aspects of 
the way GIMP works. 
 

 
 
Some of the common settings are: 
 

 Default Image 
o Sets the default new file options such as Image Size (width, height and 

orientations). 
o Also used to set the default resolution and colour mode for new files. 
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 Display 
o Sets the appearance of Transparency in the Layers dialog. 
o Choose the check box style from the Check style drop down list. 
o Choose the check box size from the Check size drop down list. 

 

 
 
 
 
Setting Measurement Units 
 
GIMP offers many different measurement units for us to work with. The unit will be 
used whenever we are creating new files, drawing preset shapes or displaying 
grids. 
 
To set the default measurement unit: 
 

1. Choose Edit > Units. 
 



Lesson 7 – Enhance Productivity  ICDL Image Editing 

Page 42   © 2016 

 
 

2. Check or uncheck the measurement units required. 
 

3. Click Close. 
 
 

7.2 USING THE HELP FUNCTION 

 
To access GIMP Help: 
 

1. Choose Help > Help or press F1. 
 

2. Click the expand icon on the left side on the window. 
 

3. Browse through the topics on the left and double click on the topic to 
access the help. 
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7.3 USING MAGNIFICATION AND ZOOM TOOLS 

 
When we work with GIMP files, we will often view them from different 
perspectives. We use the Zoom tool to enlarge and reduce the image on screen. 
 

 To zoom in, choose the Zoom tool  and then click or click and drag in 
the image. When we zoom in, the zoom percentage increases. The current 
zoom percentage is shown in the status bar. The zoom percentage shows 
the magnification at which we are viewing the image (not the actual size of 
the image). 
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 To zoom out, press the CTRL key while clicking with the Zoom tool. 
 
 

7.4 PERFORMING UNDO AND REDO WITH UNDO 

HISTORY 

 
To undo the last action, simple choose Edit > Undo <action name> (CTRL Z). 
 
The Undo History dialog records our actions and maintains minimal 5 actions. 
We can click a state in the list to go back to that point of our work, and then 
continue working from that state. 
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Action Command 

 
Undo the last action Click on the last state in the Undo History 

dialog or press CTRL Z. 

 
Redo the last action Click on the next state in the Undo History 

dialog that was undone or press CTRL Y. 

 
Revert to the state the file was last saved 

 
Choose File > Revert. 

 
 

7.5 MANIPULATING TOOLBOX AND PANELS 

 

Action Command 

 
To hide or show all docks Press TAB. 

 
To change dock displays 

 
Click on Configure this tab > Tab Style. 
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To combine tabs together Click on the tab name, drag and drop below 
another tab or next to the panel’s name. 
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7.6 REVIEW EXERCISE 

 
1. Which tool is used to enlarge and reduce the view of an image? 

 
 
 

2. Which keyboard key is used to activate the Help function? 
 
 
 

3. What happens when we press TAB? 
 
 
 

4. In GIMP, do the following: 
a. Open all the images in the Turkey Travel folder. 
b. Use the file tab to activate the image Mount Nemrud. 
c. View the image at 100% zoom level. 
d. Pan the image so that the face structure on the left is fully visible. 
e.  Fit the image on screen. 
f. Save the image as JPEG format using the file name Nemrud-Medium. 
g. Close all open images. 

 



LESSON 8 – 

SELECTION TECHNIQUES 

 

In this section, you will learn about: 
 

 Selecting an entire image or layer 

 Selecting with marquee and lasso tools 

 Setting selection tool properties 

 Selecting based on colour 

 Feathering and anti-aliasing 

 Inversing selection 

 Saving and loading selections 
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8.1 ABOUT SELECTION TECHNIQUES 

 
A selection isolates one or more parts of our image. By selecting specific areas, 
we can edit and apply effects and filters to portions of our image while leaving the 
unselected areas untouched. 
 
GIMP provides separate sets of tools to make selections of raster and vector data. 
For example, to select pixels, we can use the marquee tools or the lasso tools. 
We can use commands in the Select menu to select all pixels and to deselect. 
  
To select vector data, we can use the Paths tool as a selection tool: any closed 
path can be converted into a selection. It also can do a great deal more, though, 
and does not share the same set of options with the other selection tools.  
 
Selections can be copied, moved, and pasted, or saved. 
 
 

8.2 SELECTING AN ENTIRE IMAGE OR LAYER 

 
We can select all visible pixels on a layer or deselect any selected pixels. 
 

 Select all pixels (entire image) on a layer 
o Select > All   CTRL A 

 

 Deselect selection 
o Select > None  CTRL SHIFT D 

 
 

8.3 SELECTING WITH MARQUEE AND LASSO TOOLS 

 
Selecting with Marquee Tools 
 
The marquee tools are used to select rectangles and ellipses. 
 

   Rectangle Select 
Makes a rectangular or square selection.  

 

   Ellipse Select 
Makes an elliptical or circle selection. 

 
Selection techniques: 
 

 Holding down SHIFT while dragging constrains the marquee to a square 
or circle (press SHIFT after starting to drag and release the mouse button 
before releasing SHIFT to keep the selection shape constrained).  
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 To drag a marquee from its center, hold down CTRL after beginning to 
drag. 

 

 
 
 

Selecting with the Lassos 
 

  Free Select 
Useful for drawing freeform and straight-edged segments of a selection 
border. 
 

  Scissors Select 
The border snaps to the edges of defined areas in the image and is 
especially useful for quickly selecting objects with complex edges set 
against high-contrast backgrounds. 

 
Using the Free Select Tool 
 

1. Select the Free Select tool . 
 

2. Drag to draw a freehand selection border. 
 

 To draw a straight-edged selection border: Position the pointer where 
we want the first straight segment to end, and click. Continue clicking to 
set endpoints for subsequent segments. 
 

 To erase recently drawn segments: Press the BACKSPACE key.  
 

 To close the selection border: Position the tool pointer over the starting 
point (a filled circle appears next to the pointer), and click.  
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The Free Select is a quick way to select an area but does not allow us to select it 
precisely. All we do is click, hold and draw to create a selection. After we release 
our click the selection completes itself. 
 
The polygonal selection lets us create more accurate lines as we create straight 
lines so we have more control of what we want to select and is much more 
flexible.  
 
To start using this tool all we do is click onto our picture which creates an anchor 
point and then start clicking around the area we want to select. With this tool we 
do not have click and drag. To finish the selection we can click onto the 1st point 
where we started off or double click anywhere on the picture, as this will draw a 
straight line to the 1st point.  
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Using the Scissors Select Tool 
 

1. Select the Scissors Select tool . 
 

2. Click in the image to set the first fastening point. Fastening points anchor 
the selection border in place.  
 

3. To draw a freehand segment, click and drag the mouse pointer. 
 
The tool finds the point of the maximal gradient (where the colour change 
is maximal) for placing a new control node or moving an existing node. 
 
Each time we left click with the mouse, we create a new control point, 
which is connected to the last control point by a curve that tries to follow 
edges in the image.  
 

4. To finish, click on the first point. 
 
We can adjust the curve by dragging the control nodes, or by clicking to 
create new control nodes.  
 

5. When we are satisfied, click anywhere inside the curve to convert it into a 
selection.  
 

 

 
 

Marquee Tool Options 
 
Tool options for Rectangle Select and Ellipse Select tool: 
 



ICDL Image Editing   Lesson 8 –Selection Techniques 

© 2016   Page 53 

 
 
Tool options for Free Select and Scissors Select tool: 
 

 
 
 

 Antialiasing: Smoothens the jagged edges of a selection by softening the 
colour transition between edge pixels and background pixels. Since only the 
edge pixels change, no detail is lost. Antialiasing is useful when cutting, 
copying, and pasting selections to create composite images. Turning off this 
option produces a hard-edged transition between pixels–and therefore the 
appearance of jagged edges. 
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 Feather Edges: Blurs edges by building a transition boundary between the 
selection and its surrounding pixels. This blurring can cause some loss of 
detail at the edge of the selection. 
 

 Rounded corners: A slider appears and we can use this to adjust the radius 
that is used to round the corners of the selection. 
 

 Expand from center: Allows the selection to be drawn from the center of the 
mouse click. 
 

 Fixed: We can define width, height or proportion of selection by using this 
option. 
 
o Aspect ratio to set a height-to-width ratio. By default the ratio is 1:1. 

 
o Width to specify width of selection. 

 
o Height to specify height of selection. 

 
o Size to specify both width and height of selection.  

 

 

8.4 SELECTING BASED ON COLOUR 

 
Selecting with the Select by Color Tool 
 

We can use the Select by Color tool  to select areas of an image based on 
colour similarity. It works a lot like the Fuzzy Select tool. The main difference 
between them is that the Fuzzy Select tool selects contiguous regions, with all 
parts connected to the starting point by paths containing no large gaps; while the 
Select by Color tool selects all pixels that are sufficiently similar in colour to the 
pixel you click on, regardless of where they are located. 
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Select by Color Tool Options 
 

 
 

 Antialiasing: Smoothens the jagged edges of a selection.  
 

 Feather edges: Blurs edges of a selection.  
 

 Select transparent areas: Select areas that are completely transparent.  
 

 Sample merged: Relevant when we have several layers in our image, 
whether to sample from current layer only, or from all visible layers. 
 

 Threshold: Determines the range of colours that will be selected at the 
moment we click the pointer on the initial point, before dragging it: the 
higher the threshold, the larger the resulting selection. After the first click, 
dragging the pointer downward or to the right will increase the size of the 
selection; dragging upward or to the left will decrease it. Thus, we have the 
same set of possibilities regardless of the Threshold setting: what differs is 
the amount of dragging we have to do to get the result we want. 

 

 
Selecting with the Fuzzy Select (Magic Wand) Tool 
 

The Fuzzy Select (Magic Wand) tool  lets us select an area by colour range 
without having to trace its outline. We can specify the colour range, or tolerance, 
for the Magic Wand tool's selection.  
 
Enter a low value to select the few colours very similar to the pixel we click, or 
enter a higher value to select a broader range of colours. 
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Fuzzy Select Tool Options 
 

 
 
The options for the Fuzzy Select tool is the same for Select by Color tool. 
 
 

8.5 MANIPULATING SELECTIONS 

 
There a four selection modes in the tool options tab. 
 

 
 

 Replace 
 

 Add 
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 Subtract 
 

 
 

 Intersect 
 

 
 
 

8.6 FEATHERING AND ANTI-ALIASING 

 
Selection feather will soften the edge of selection. The default feather is 0px that 
will produce crispy and jagged edge. This will be more noticeable in very higher 
resolution image. 
 

 
 
Selection feather is very useful, especially when making selection to adjust blur or 
out-focus object. By using appropriate amount of feather, the image will look more 
natural.  
 
The amount of feather will vary depend on resolution of image. Specific amount of 
feather that produce best result in one image may not work with the other image if 
the image resolution is greatly different. 
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Applying Selection Feather 
 

1. Create a selection. 
 

2. Choose Select > Feather.  
 

 
 

3. Enter required feather radius. 
 

4. Click OK. 
 
 

8.7 INVERSING SELECTION 

 
We can select the unselected parts of an image by inversing the current selection. 
We can use this option to select an object placed against a solid-coloured 
background. The background can be selected using the Fuzzy Select or Select 
by Color and then inverse the selection. 
 

   
Original selection   Inversed selection 
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Inversing Selection 
 

1. Create a selection. 
 

2. Choose Select > Invert. 
 

8.8 SAVING AND LOADING SELECTIONS 

 
We can save any selection in a new channel and later reload the selection. 
 
To save a selection: 
 

1. Use a selection tool to select the area. 
 

2. Choose Select > Save to Channel. 
 

3. Enter a name for the selection in the Channels tab. 
 

4. Press ENTER. 
 

 
 
To load a saved selection: 
 

1. Right-click on the named channel. 
 

2. Click on Channel to Selection. 
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8.9 REVIEW EXERCISE 

 
1. Open the images Wall and Frames. 
a. Use the marquee selection tools to select the framed pictures and object and 

place them on the wall image. 
b. Save the file as Wall – Completed. 

 
2. Open the image Butterfly. 
a. Use a lasso tool to select the butterfly. 
b. Save the selection. 
c. Save the file. 

 
3. Open the image Pink Rose. 
a. Select the flower. 
b. Subtract any background from the selection if necessary. 
c. Save the selection. 
d. Save the file. 

 



LESSON 9 - 

IMAGE MANIPULATION 

 

In this section, you will learn about: 
 

 Changing image canvas size 

 Resizing images 

 Cropping images 

 Moving and copying image or selection 

 Rotating and flipping image or selection 
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9.1 CHANGING IMAGE CANVAS SIZE 

 
The canvas size is the full editable area of an image. The Canvas Size command 
lets us increase or decrease an image’s canvas size. By default the size of the 
canvas coincides with the size of the layers. 
 
When we enlarge the canvas, we create free space around the contents of the 
image. When we reduce it, the visible area is cropped, however the layers still 
extend beyond the canvas border. 
 
When we reduce the canvas size, the new canvas appears surrounded with a thin 
negative border in the preview. The mouse pointer is a moving cross: click and 
drag to move the image against this frame. 
 

1. Choose Image > Canvas Size. 
 

2. Do one of the following:  
 

 Enter the dimensions for the canvas in the Width and Height boxes.  
 

 Choose different units, e.g. percent, if we want to set the new 
dimensions relative to the current dimensions. 
 

 Break the Chain by clicking on it, to set Width and Height separately.  
 

3. Set Offset values to place the image on the canvas or click the Center 
button to center the image on the canvas. When we click on the Center 
button, the offset values are automatically calculated and displayed in the 
text boxes. 
 

4. Click Resize.  
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9.2 RESIZING IMAGES 

 
Image size refers to the dimensions of the GIMP file. The Scale Image command 
enlarges or reduces the physical size of the image by changing the number of 
pixels it contains. It changes the size of the contents of the image and resizes the 
canvas accordingly. 
 

1. Choose Image > Scale Image. 
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2. Enter the required Width and Height. 
 

3. Set the printing resolution for the image in the X resolution and Y 
resolution fields. 
 

4. Click Scale. 
 
To change the image size, either some pixels have to be removed or new pixels 
must be added. The process we use determines the quality of the result. The 
Interpolation drop down list in the Scale Image dialog provides a selection of 
available methods of interpolating the colour of pixels in a scaled image. 
 
These different methods have an impact on the perceived sharpness and 
smoothness of the resulting image. 
 
The different resampling options are: 
 

 None 
No interpolation is used. Pixels are simply enlarged or removed, as they 
are when zooming. This method is low quality, but very fast. 
 

 Linear 
This method is relatively fast, but still provides fairly good results. 
 

 Cubic 
The method that produces the best results, but also the slowest method. 
 

 Sinc (Lanczos 3) 
New with GIMP 2.4, this method gives less blur in important resizing. 

 
When changing image size relatively small amounts (say scaling up or down less 
than 10%), it may not be necessary to change the default setting of (Cubic), but 
when making large changes be certain to choose the appropriate option for the 
maximum quality.  
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9.3 CROPPING IMAGES 

 
One of the first editing tasks we will probably undertake is cropping an image 
photo. There are different ways to crop in GIMP. We will start with the basic and 
then we will look at some ways to make the task faster and easier. 
 
Cropping is the process of removing portions of an image to create focus or 

strengthen the composition. We can crop an image using the Crop tool  and 
the Crop to Selection command (Image > Crop to Selection). We can also trim 
pixels using the Autocrop Image and the Zealous Crop commands. 
 

 
Using the Crop Tool 
 
The Crop tool works similarly to the Rectangular Select tool. We can drag to 
draw rectangular area to select part of image we want to include. Moreover Crop 
tool include bounding box around selected area that allows us to resize, move or 
perspective the select area. We can also crop and resize our selected area to 
target resolution that we specify in tools option. 
 

 
 
 
To crop an image using the Crop tool: 
 

1. Select the Crop tool. 
 

2. Set resample options in the Tool Options tab. 
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3. Drag over the part of the image we want to keep to create a marquee. If 
necessary, adjust the cropping marquee. 

 
4. Press ENTER or click inside the cropping marquee. 

 

 
Using Autocrop Image Command 
 
The Autocrop Image command removes the borders from an image. It searches 
the active layer for the largest possible border area that is all the same colour, and 
then crops this area from the image. 
 

1. Open an image file. 
 

2. Choose Image > Autocrop Image. 
 
 

   
    Original image     Image after applying 
           Autocrop Image  

command 
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9.4 MOVING AND COPYING IMAGE 

 
To move a selection: 
 

1. Place the selection tool pointer inside the selection border. 
 

2. Drag the selection to a new position. 
 

 
 
To copy a selected image area: 
 

1. Select the required image area. 
 

2. Choose Edit > Copy. 
 

3. Choose Edit > Paste. 
 
To move an image: 
 

1. Select the Move tool. 
 

2. Drag the image to a new position. 
 
To copy an image: 
 

1. Choose Image > Duplicate. 
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9.5 ROTATING AND FLIPPING SELECTION/IMAGE 

 
Rotating Image 
  
There may be times when we open an image in GIMP to find that it is not in its 
proper orientation.  
 
To rotate an image: 
 
The Image > Transform commands let us rotate or flip an entire image. The 
commands do not work on individual layers or parts of layers, paths, or selection 
borders.  
 

1. Choose Image > Transform. 
 

2. Choose one of commands from the submenu. 
 

a. Rotate 180°     
 

 
 
 

b. Rotate 90° clockwise   
 

 
 

c. Rotate 90° counter-clockwise  
 

 
 
 To rotate the image by a specify angle: 
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1. Select the Rotate tool . 
  

2. Click on the image. 
 

 
 

3. Enter the required angle. 
 

4. Click Rotate. 
 

 
 

 
Mirroring Image 
 
To mirror/flip an image you can use the following commands:  
 

1. Choose Image > Transform. 
 

2. Choose one the commands from the submenu. 
 

a. Flip Horizontally: Mirrors the image as to the standing axis, i.e. 
interchanges the left and the right parts of the image. 
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b. Flip Vertically: Mirrors the image as to the horizontal axis, i.e. it turns the 
image upside down.  
 

 
 

 
Selection within an Image 
 
To rotate a selection: 
 

1. Select an area of the image using the selection tool of our choice. 
 

2. Select the Rotate tool . 
 

3. Click inside the selection marquee. 
 

4. Enter the required angle. 
 

5. Click Rotate. 
 
 
To mirror/flip a selection: 
 

1. Select an area of the image using the selection tool of our choice. 
 

2. Select the Flip tool . 
 

3. Click inside the selection marquee. 
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9.6 REVIEW EXERCISE 

 
1. Add additional 10% of black canvas area all around the image Bottle. 

 
2. Crop the image Deck Chairs to a width of 3 inches by a height of 2 inches. 

Ensure only the chairs are visible. 
 

3. Crop and straighten the images in Scanned Photos. Rotate the yacht image as 
necessary. Save the images as Beach1, Beach2 and Beach3. 
 

4. Trim away the excess blank space in the image Old TV. 
 

5. In the file Blue Butterfly, extend the canvas on right and create the other half of 
the butterfly. Trim away excess canvas area. 
 



LESSON 10 – 

LAYERS 

 

In this section, you will learn about: 
 

 Understanding layers 

 Creating, copying and deleting layers 

 Setting layer properties 

 Merging and flattening layers 

 Transforming layers 

 Rasterizing layers 

 Creating animated GIF from layers 
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10.1 UNDERSTANDING LAYERS 

 
GIMP layers are like sheets of transparencies. We can see through transparent 
areas of a layer to the layers below. We move a layer to position the content on 
the layer, like sliding a sheet in a stack. We can also change the opacity of a layer 
to make content partially transparent. 
 

  
 
We use layers to perform tasks such as compositing multiple images, adding text 
to an image, or adding vector graphic shapes. We can apply a layer style to add a 
special effect such as a drop shadow or a glow. 
 
The organization of layers in an image is shown by the Layers dialog.  Each open 
image has at any time a single active drawable. A “drawable” includes layers, but 
also several other types of things, such as channels, layer masks, and the 
selection mask. (Basically, a “drawable” is anything that can be drawn on with 
painting tools).  
 
If a layer is currently active, it is shown highlighted in the Layers dialog, and its 
name is shown in the status area of the image window. If not, we can activate it by 
clicking on it. If none of the layers are highlighted, it means the active drawable is 
something other than a layer. 
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10.2 CREATING, COPYING AND DELETING LAYERS 

 
Creating New Layer 
 
To create a new layer: 
 

1. Click on the New Layer icon at the bottom of the Layers dialog or choose 
Layer > New Layer. 
 

Modes 

Opacity 

Lock pixels 

Lock alpha channel 

Visibility 

Layers 

       
New layer  

New layer group  

Raise layer up  

Lower layer down  

Duplicate layer  

Anchor floating layer  

Delete layer  
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2. Enter the layer properties and click OK.  
 

 
 
A new layer appears above the current layer. 
 
Copying Layers 
 
We can make a copy of an existing layer by using any of the methods mentioned 
below: 
 

 Choose Layer > Duplicate Layer. 
 

 Right click on the layer thumbnail in the Layers dialog and choose 
Duplicate Layer. 
 

 Press CTRL SHIFT D. 
 
Rearranging Layers 
 
We can move layers above and below each other in the Layers dialog simply by 
dragging them.  
 
To move a layer, click and drag it above or below another layer. Release the 
mouse button when the highlight bar appears, and GIMP drops the layer into its 
new position. 
 
The Layer > Stack submenu contains the commands: 
 

 Raise Layer 
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 Lower Layer 
 

 Layer to Top 
 

 Layer to Bottom. 
 
These commands can also be used for moving layers within the stacking order. 
 
Deleting Layers 
 
To delete a layer, simply right click on its' thumbnail in the Layers dialog and 
choose Delete Layer. We also can drag it down onto the Trash Bin icon at the 
bottom of the Layers dialog. 
 

 
 
Selecting and Moving Layer Content 
 

The Move tool  is used to move, transform, align and distribute layer 
elements. When used on a layer with no selections, it will reposition all the objects 
on that layer. If a selection has been made, only the selected pixels will be moved. 
 

 10.3 SETTING LAYER PROPERTIES 

 
Renaming Layers 
 
GIMP automatically names layers for us as we add them, but the names it gives 
them, like "Layer 1" and "Background copy", are pretty generic and not very 
helpful. When we only have a couple of layers in a document, the names may not 
seem very important, but when we find ourselves working with multiple layers, it is 
much easier to keep them organised if they have meaningful names.  
 
To rename a layer, simply double-click directly on a layer's name in the Layers 
dialog, then type in a new name. When done, press ENTER. 
 

 
The Layer Visibility Icon 
 

We can hide layers by clicking on its layer visibility icon . When the little eyeball 
is visible in the box, it means the layer is visible in the document. Clicking the icon 
will hide the eyeball and hide the layer. 
 

 
 

 
Linking Layers 
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We can link layers by clicking the white space to the right of the layer visibility icon

.  

When the link chain icon is visible in the box, it means these layers are being 
linked in the document. Clicking the icon again will remove the link. 
 

 
Locking Layers 
 
Layers panel also gives us a few different ways that we can lock certain aspects 
of a layer.  
 
For example, if part of a layer is transparent, we can lock the transparent pixels so 
that we are only affecting the actual contents (the image pixels) on the layer. Or 
we can lock the image pixels.  
 
There are two lock options to choose from, each represented by a small icon, and 
they are located just below the opacity settings in the Layers dialog. From left to 
right, we have Lock pixels and Lock alpha channels. 
 

 
 

  Lock pixels 
This will lock all transparent and opaque pixels on a layer. When in effect, we 
cannot make any editing changes to the layer.  
 

  Lock alpha channels 
This will lock all transparent pixels on a layer. When in effect, we cannot apply any 
changes to transparent pixels.  

 
 

Layer Opacity 
 
Another one of the features of using layers is that we can blend them together in 
interesting ways. The most simple and speedy way to blend layers together is by 
using opacity. 
 
Opacity is the opposite of transparency. If something has an opacity value of 
100%, which means it’s completely visible (opaque). An opacity value of 0% 
indicates that an object is completely transparent. 
 
 
 

 
 
To change the layer opacity, click on the up or down button to the right of the 
Opacity value. We can also double-click on the Opacity value and type a new 
value. 
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Layer Blend Modes 
 
Blending modes can be used to create a variety of effects by blending pixels in a 
layer or between layers. GIMP contains a number of blending modes. Some of the 
blending modes are Difference, Multiply, Overlay, Hard Light, and Soft Light.  
 

 
 
A blending mode takes the colour values of two layers and combines them using 
a formula, so it is more sophisticated than just changing opacity. Some blending 
modes happen to have effects that conveniently help us with basic tone and 
colour edits, and all we have to do is copy a layer on top of the original and apply 
a blending mode to the copy. 
 
It is helpful to think in terms of following colours when visualizing a blending 
mode’s effect: 
 

 The base colour is the original colour in the image. 
 

 The blend colour is the colour being applied with the painting or editing 
tool. 
 

 The result colour is the colour resulting from the blend. 
 
 
Types of Blend Modes 
 

 
 

Mode 

 
Description 
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Mode 

 
Description 

Independent 

 Normal 

 Dissolve 

Replaces the underlying pixels with the pixels of the applied 
layer when the layer is at 100 percent opacity. At lower 
opacities, Normal blends the overlying pixels with the 
underlying ones according to the layer Opacity value, while 
Dissolve replaces pixels randomly. 

 
Lighten 

 Lighten only 

 Screen 

 Dodge 

 Addition 

The Lighten modes are the inverse of the Darken modes. The 
neutral colour for the Lighten modes is black—black pixels on 
a layer set to a Lighten mode leave the underlying pixels 
unchanged. Nonblack pixels darken the result by varying 
amounts, depending on each blending mode’s math and the 
difference in value between the applied and underlying pixels. 

 
Darken 

 Darken only 

 Multiply 

 Burn 

The neutral colour for the Darken modes is white. White pixels 
on a layer set to a Darken mode leave the underlying pixels 
unchanged. Non-white pixels darken the result by varying 
amounts, depending on each blending mode’s math and the 
difference in value between the applied and underlying pixels. 

 
Contrast 

 Overlay 

 Soft light 

 Hard light 

These modes combine corresponding Darken and Lighten 
modes. The neutral colour for the Contrast modes is 50 
percent gray—50 percent gray pixels on a layer set to a 
Contrast mode leave the underlying pixels unchanged.  

 
Lighter pixels lighten the result and darker pixels darken the 
result; the amount depends on the blending mode and the 
value difference between the applied and underlying pixels. 

 
Comparative 

 Difference 

 Exclusion 

 Grain extract 

 Grain merge 

 Divide 

The neutral colour for the Comparative modes is black. The 
Comparative modes look at each channel and subtract the 
underlying colour from the overlying colour or the overlying 
colour from the underlying colour, whichever returns a result 
with higher brightness. Blending with white inverts the 
underlying colour values. 

 

 
 

Mode 

 
Description 

HSL 

 Hue 

 Saturation 

 Colour 

 Value 

Blending modes in other groups generally operate on overall 
tone and colour values. The members of the HSL group work 
with hue, saturation, and luminosity (HSL) instead 
 

 Hue. This blending mode creates a result colour with the 
brightness and saturation of the underlying colour and the 
hue of the overlying colour. 

 Saturation. This mode creates a result colour with the 
brightness and hue of the underlying colour and the 
saturation of the overlying colour.  

 Colour. This mode creates a result colour with the 
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luminosity of the underlying colour and the hue and 
saturation of the overlying colour.  

 Value. This is the inverse of the Colour blending mode. It 
creates a result colour with the hue and saturation of the 
underlying colour and the luminosity of the overlying 
colour. 

 

 
 

10.4 MERGING AND FLATTENING LAYERS 

 
We can merge layers to reduce the size of our image files. When we merge 
layers, the data of the top layers replaces any data that it overlaps on the lower 
layers. 
 
To merge layers: 
 

1. Ensure the layers to be merged are visible. 
 

2. Choose Image > Merge Visible Layers. 
 

3. Select the required merge options. 
 

 
 

4. Click Merge. 
 
Flattening reduces file size by merging all visible layers into the background and 
discards hidden layers. Any remaining transparent areas are filled with white. 
When we save a flattened image, we cannot revert back to the un-flattened state, 
the layers are permanently merged. 
 
To flatten layers: 
 

1. Ensure the layers are visible. 
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2. Choose Image > Flatten Image. 

 

10.5 TRANSFORMING LAYERS 

 
Transforming scales, rotates, flips, moves, or trims a layer. We can apply 
transformations to a selection, an entire layer, multiple layers, or a layer mask.  
 
To make a transformation, first select an item to transform and then choose a 
transformation command. We can perform several manipulations in succession 
before applying the cumulative transformation.  
 
To transform selection, choose Layer and choose a submenu. 
 

 Scale a layer 
o Choose Layer > Scale Layer 
o Set the required options. 
o Click Scale. 

o For freeform scaling, use the Scale tool .  
 

 Rotate or flip a layer  
o Choose Layer > Transform. 
o Select a flip option or rotation angle and direction. 

o For freeform rotation, use the Rotate tool . 
 

 Move a layer 
o Choose Layer > Transform > Offset. 
o Set the required options and click Offset. 

o For freeform moving, use the Move tool . 
 
 

 Trim a layer 
o Choose Layer > Autocrop Layer. 

 

10.6 RASTERIZING LAYERS 

 
We cannot use the painting tools or filters on layers that contain vector data (such 
as type layers or shape layers. In this case, we can rasterize these layers to 
convert their contents into a flat, raster image. 
 

1. Select the layers to rasterize. 
 

2. Choose Image > Flatten Image. 
 

3. Save the file as a raster format (e.g. JPEG). 
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To rasterize a text layer, right click on the layer thumbnail and choose Discard 
Text Information. 
 
  

10.7 CREATING ANIMATED GIF FROM LAYERS 

 
The first step in creating any animation in GIMP is to build a layered GIMP file with 
all the elements we plan to animate. 
 

1. On the each layer, create the content frame. 
 

2. Enter the amount of milliseconds each layer is to appear in the animation 
by entering this number in parentheses followed by "ms" next to the layer 
name. For example: (1500ms). 
 

 
 

3. To preview the animation, choose Filters > Animation > Playback. 
 

4. Choose File > Export. 
 

5. Set file type to GIF. 
 

6. Enter a filename and click Export. 
 

7. Check the option As animation. 
 

8. Set the frame delay as required. 
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9. Click Export. 
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10.8 REVIEW EXERCISE 

 
1. Creating a web pop-up advertisement: 
a. Create a new image document using the following settings: 
i. Width:  640 px 
ii. Height:  450 px 
iii. Resolution: 72 
iv. Colour mode: RGB 
v. Background: Transparent 

 
2. Place City into the new file, scale so that it fills the canvas and name the layer as 

City. 
 

3. Use Desaturate command (Colors menu) to remove the colours from the City 
layer and set the opacity of the layer to 60%. 
 

4. Place Park into the new file and name the layer as Park. 
 

5. Place Sunglasses into the new file. 
 

6. Select the circular area inside the glasses and copy the selection into a new layer. 
Name the layer as Lenses. 
 

7. Place the Park layer above the Lenses layer. 
 

8. Mask the layers Lenses and Park layers (right click > Add Layer Mask).  
 

9. Make the Park layer the active layer and using the Move tool to shift the park 
image around until it is framed the way we like it within the glasses. 
 

10. Make City the active layer, place Green City Text image into the new file and 
move the layer all the way to the top in the Layer dialog.  
 

11. Center the text horizontally and position it below the glasses. 
 

12. Save the file as Web Ad in GIMP format. 
 

 



LESSON 11 – 

WORKING WITH TEXT 

 

In his section, you will learn about: 
 

 Creating and editing text 

 Formatting text 

 Applying text wrap 
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11.1 CREATING AND EDITING TEXT 

 
When we create text, a new text layer is added to the Layers dialog. After 
creating a text layer, we can edit the text and apply layer commands to it. There 
are 3 ways to create type: 
 

 Point type: A horizontal or vertical line of text that begins where we click in 
the image. 
 

 Paragraph type: Uses boundaries to control the flow of characters, either 
horizontally or vertically. 
 

 Type on a path: Flows along the edge of an open or closed path. 
 
To enter text: 
 

1. Select the Text tool . 
 

2. Click in the image to set an insertion point. 
 

3. Type the text. 
 
To edit the text, simply double click on the layer thumbnail and edit as required. 
To delete a text layer, right click on the layer thumbnail and choose Delete Layer. 
 
To copy the text: 
 

1. Highlight the text. 
 

2. Right click > Edit > Copy. 
 

3. Position the cursor as necessary ar create a text layer. 
 

4. Right click > Edit > Paste. 

 
To move the text, use the Move tool to move the entire text layer, else use Edit > 
Cut and then Edit > Paste to move within the existing text box. 

 

11.2 FORMATTING TEXT 

 

 
 
Modifying text using the Tool Options 
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To set an option in the Tool Options dialog, we first select the text we want to 
change. For each option in the panel, choose a value from the pop-up menu, click 
an icon or type a value. When we type a value directly, press ENTER to apply it. 
 

 
 
The options in the Tools Options include the following: 
 
Font 

 
 

Font size 

 
 
Anti-aliasing 
 

 
 
 
Font Colour 
 

 
 
Clicking on the colour box displays the Text Color dialog box. Use the options 
provided to set a font colour. 
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Alignment 
 

 
 
We can change the text's alignment — whether the text lines up with the left, right, 
or center of the text box. We can also justify the text. 
 
 
Indentation, Leading and Tracking 
 

 
 
Leading: Space between lines. 
 
Tracking: Space between characters. 
 
 

11.3 APPLYING TEXT WARP 

 
We can also curve, or warp, text by using the filter Curve Bend option to create 
special type effect. 
 
To warp type: 
 

1. Select the Text tool. 
 

2. Select the text we wish to warp. 
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3. Choose Filter > Distorts > Curve Bend. 

 

 
 

4. Check the option Automatic preview. 
 

5. Use the mouse to bend the curve the way we like.  
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11.4 REVIEW EXERCISE 

 
1. Create a collage or image composition to depict the colour wheel that contains all 

12 colours (3 primary, 3 secondary, and 6 tertiary). 
 

2. Use the following website to read up on the colour wheel: 
http://en.wikipedia.org/wiki/Colour_wheel. 
 

3. The artwork dimension should be 700 by 700 pixels with 150 ppi resolution. 
 

4. Label all of the colours correctly. 
 

5. Save the file as Wheel Illustration. 
 
 
 



 

LESSON 12 - 

EFFECTS AND FILTERS 

 

In this section, you will learn about: 
 

 Applying artistic and distortion effects 

 Applying blur effects 

 Applying lighting effects 

 Working with image adjustments 

 Working with sharpen and unsharp mask 

 Applying red eye reduction 
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12.1 UNDERSTANDING EFFECTS AND FILTERS 

 
Filters are a large group of effects that we can apply to images. Filters can be 
anything from blurs to textures to distortions, and everything in between. One 
thing is common to most filters: they modify the existing pixels of the layer they 
are applied to. 
 
In GIMP, filters are classified into many groups based on the effect they have on 
an image. Filter groups include Artistic, Blur, and Texture. Each filter group 
contains individual filters that apply a certain effect to the image. Some of the 
individual filters are the Sponge that simulates sponge painting; Grain that adds 
texture to an image by simulating different types of grains; and Blur that softens 
the entire image or a selection. 
 
 

12.2 APPLYING ARTISTIC AND DISTORTION EFFECTS 

 
The Pixelate Filter 
 
Choose Filters > Blur > Pixelize. 
 

 
 
This filter breaks up the image, or reduces its resolution. It sharply defines a 
selection by clumping pixels of similar colour values in cells.  
 
We can set the desired width and height of the blocks. 
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The Emboss Filter 
 
Choose Filters > Distorts > Emboss. 
 
It makes a selection appear raised or stamped by converting its fill colour to gray 
and tracing the edges with the original fill colour. 
 

 
 
 
The Wind Filter 
 
Choose Filters > Distorts > Wind. 
 
Creates tiny horizontal lines in the image to simulate a wind effect. Note that this 
filter only works horizontally, so the image needs to be rotated if the effect is to be 
vertical. 
 
Style: Wind determines the high-contrast areas and displaces them using a 
jagged pattern of fading stripes; Blast is a more dramatic version of Wind in the 
entire image. 
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The Ripple Filter 
 
Choose Filters > Distorts > Ripple. 
 
Creates an undulating pattern on a selection, like ripples on the surface of a pond. 
 



Lesson 12 – Effects and Filters  ICDL Image Editing 

Page 96   © 2016 

 
 
 
The Twirl Filter 
 
Choose Filters > Distorts > Whirl and Pinch. 
 
Rotates a selection more sharply in the center than at the edges. Specifying an 
angle produces a twirl pattern. Positive angles twirl clockwise, negative amounts 
anti-clockwise. 
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Desaturate 
 
Choose Colors > Desaturate. 
 

 
 
The Desaturate effect converts all of the colours on the active layer to 
corresponding shades of gray. This command only works on RGB images. 
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12.3 APPLYING BLUR EFFECTS 

 
Gaussian Blur 
 
Choose Filters > Blur > Gaussian Blur. 
 

 
 
Named after German mathematician Carl Friedrich Gauss, this is the most widely-
used of the blurs as it uses a special function to produce a natural-looking blur. 
Gaussian Blur is used everywhere, from creating drop shadows to smoothing the 
pixelated edges of objects, and simulating photographic depth-of-field. 
 
Blur Radius is used to set the blur intensity. By altering the ratio of horizontal to 
vertical blur, we can give the effect of a motion blur. We can choose the unit with 
the drop list. 
 
Blur Method IIR (Infinite Impulse Response) works best for large radius values 
and for images which are not computer generated. 
 
RLE (Run-Length Encoding) is best used on computer-generated images or those 
with large areas of constant intensity. 
 

 
Motion Blur 
 
Choose Filters > Blur > Motion Blur. 
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Similar to Gaussian Blur but applied in one direction. Can be used to create 
custom stroke effects and, of course, to make something stationary appear to be 
moving. 
 
Try applying this filter to a duplicate layer, offsetting it and then reducing its 
transparency for a better result. 
 
 
Applying Lighting Effects 
 
The Lighting Effects filter allows us to create myriad lighting effects on RGB 
images.  
 

1. Choose Filter > Light and Shadow > Lighting Effects.  
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2. In the Options tab, specify the distance of the light source from the center 
of the image with this slider. 
 

3. Set the light properties in the Light tab. 
 

4. Set the material properties in the Material tab. 
 

5. Click OK. 
 
 
Lens Flare 
 
Lens flare stimulates the refraction caused by shining a bright light into a camera 
lens. We specify a location for the center of the flare by clicking anywhere inside 
the image thumbnail of by dragging its cross hair. 
 
Choose Filters > Light and Shadow > Lens Flare. 
 
 

12.5 WORKING WITH IMAGE ADJUSTMENTS 

 
Adjustments are a quick and accurate way to edit any picture or image by simply 
clicking on one of the Adjustment options shown on it. We will be able to edit the 
colours, saturation, levels, channels, mix colours and add gradients. 
 
Brightness and Contrast 
 
Choose Colors > Brightness-Contrast. This is one of the simplest adjustments 
and yet very powerful. 
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We can simply edit the tonal range of an image in a very smart way. Just move 
the sliders to adjust our desired settings. 
 
 
Hue and Saturation 
 
Another must-know Adjustment, Hue-Saturation lets us adjust the hue, 
saturation, and lightness of a specific range of colours in an image or 
simultaneously adjust all the colours on it.  
 
Choose Colors > Hue-Saturation. 
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To adjust all the colours at the same time select Master on the colour list and then 
move any of the three sliders. The Hue slider changes the colour itself. 
 
The Saturation slider modifies the amount of the colour; less saturated colour 
means a grayer image. The Lightness slider adjusts the amount of black/white of 
the image. 
 
It is also possible to colourize an image from this menu and this is an easy way to 
produce an image with the look of a Cyanotype or Sepia-toned image. 
 
 
Colour Balance 
 
The Colour Balance adjustment changes the overall mixture of colours in an 
image for generalised colour correction. It basically adds something like a tint over 
the Shadows, Midtones and Highlights of the image. 
 
Choose Colors > Color Balance. 
 

 
 
 

12.6 WORKING WITH SHARPEN AND UNSHARP MASK 

 
The Sharpen filter focuses the entire image or a selection, improving its clarity. 
Choose Filters > Enhance > Sharpen. 
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The Unsharp Mask filter is borrowed from traditional photography, it basically 
enables us to sharpen an image more precisely than that offered by the Sharpen 
filter. 
 
Use the Unsharp Mask filter to adjust the contrast of edge detail and produce a 
lighter and darker line on each side of the edge. This process will emphasise the 
edge and create the illusion of a sharper image. 
 
Choose Filters > Enhance > Unsharp Mask. 
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Unsharp Mask Controls 
 

o Radius 
Determines the number of pixels surrounding the edge pixels that affect 
the sharpening. 
 

o Amount 
Determines how much to increase the contrast of pixels.  
 

o Threshold 
Determines how different a pixel must be from the surrounding area before 
it is considered an edge pixel and sharpened by the filter. 

 

12.7 APPLYING RED EYE REDUCTION 

 
Red eye is caused by the reflection of camera’s flash in the retina. We see it more 
often when taking pictures in darkened room because the iris is wide open. 
 
The Red Eye Removal filter removes red eye in flash photos. 
 

1. Select the eye area. 
 

2. Choose Filters > Enhance > Red Eye Removal. 
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3. Drag the Threshold slider to reduce the red eye effect. 
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12.8 REVIEW EXERCISE 

 
1. Search for 4 sceneries and flowers that represents the 4 seasons: spring, 

summer, autumn and winter. 
 

2. Create a mock-up of a post card design for a travel company using the dimension 
of a 4R photo with the resolution of 150 ppi. 
 

3. Apply an artistic filter to the background composition (the 4 sceneries) and reduce 
the opacity. 
 

4. Place the flowers as shown in the sample below. 
 

5. Add the text, apply warp effect and layer styles. 
 

6. Save the file as Post Card. 
 



 

LESSON 13 - 

DRAWING TOOLS 

 

In this section, you will learn about: 
 

 Working with drawing tools 

 Adding line and shapes 
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13.1 WORKING WITH DRAWING TOOLS 

 
Drawing in GIMP involves creating vector shapes and paths. Use the rectangle or 
ellipse select tools to create the shape and apply a fill colour. We can also draw 
using the Path tool.  
 
GIMP offers a very useful filter called Gfig that allows us to draw various lines and 
shapes and format them. 
 

 
 

13.2 ADDING LINES AND SHAPES 

 
Adding Lines 
 
To draw a straight line using the Path tool: 
 

1. Click on the Path tool . 
 

2. Draw the line by clicking on the starting point and then clicking on the end 
point. 

 
To draw a curved line: 
 



ICDL Image Editing   Lesson 13 – Drawing Tools 

© 2016   Page 109 

1. Click on the Path tool . 
 

2. Click once at the starting point. 
 

3. Click once at the ending point. 
 

4. Move the mouse cursor close to a line segment, click and drag the line 
segment to create the curve. 

 
Formatting Lines 
 

1. Select the drawn line (path). 
 

2. Click on the Foreground color box in the toolbox and select a colour for 
the line. 
 

3. Choose Edit > Stroke Path. 
 

4. Set the required stroke options. 
i. Weight: Use the Line width box to set the thickness of the line. 
ii. Style: Click on the plus icon to expand the Line Style options. Click 

the Dash preset drop down list to choose a line style. 
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5. Click Stroke. 

 
 
Adding Shapes 
 
To add a rectangle or ellipse: 
 

1. Create a new blank layer, if necessary. 
 

2. Choose Filters > Render >Gfig. 
 

3. In the Gfig dialog box, click on either one of the shapes below: 

a.  Create rectangle 

b.  Create circle 

c.  Create ellipse 
 

4. Click and drag on the image area to draw the shape. 
 

5. Check or uncheck the Stroke option to create the shape outline. 
 

6. Click on the Stroke color box and select a colour for the outline. 
 

7. Choose a fill type from the Fill drop down box. 
 

8. Click on the Fill box to choose a fill variation. 
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9. Click Close. 

 
 
To add a polygon or a star: 
 

1. Create a new blank layer, if necessary. 
 

2. Choose Filters > Render >Gfig. 
 

3. In the Gfig dialog box, click on Create reg polygon icon  or Create 

star icon . 
 

4. Set the number of sides using the Sides slider. 
 

 
 

5. Click and drag on the image area to draw the shape. 
 

6. Check or uncheck the Stroke option to create the shape outline. 
 

7. Click on the Stroke color box and select a colour for the outline. 
 

8. Choose a fill type from the Fill drop down box and click on the Fill box to 
choose a fill variation. 
 

9. Click Close. 
 



LESSON 14 - 

PAINTING TOOLS 

 

In this section, you will learn about: 
 

 Selecting colour with the eyedropper 

 Filling with gradient fill 

 Colouring using the paintbrush 

 Using the eraser 

 Filling with paint bucket 

 Cloning with the clone stamp 
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14.1 WORKING WITH PAINTING TOOLS 

 

The Paintbrush tool  and the Pencil tool  work like traditional drawing 

tools by applying colour with brush strokes. The Blend tool  and Bucket Fill 

tool  apply colour to large areas.  
 

Tools such as the Eraser tool , Blur tool , and Smudge tool  modify 
the existing colours in the image. 
 

14.2 SELECTING COLOUR WITH THE COLOUR PICKER 

TOOL 

 

The Color Picker tool  samples colour to assign a new foreground or 
background colour. We can sample from the active image or from anywhere else 
on the screen.  
 

1. Select the Color Picker tool . 
 

2. Change the sample size of the eyedropper from the Sample average 
option in the Tool. 
 

3. Click in the image to select a new foreground colour. 
 

 

14.3 FILLING WITH GRADIENT FILL 

 

The Blend tool  can be used to create a gradual blend of colour between one 
or more colours. We can choose from the list of gradient fills preset or create a 
whole new gradient fill preset. To fill part of the image, select the desired area. 
Otherwise, the gradient fill will be applied to the entire active layer. 
 
We can fill an area with a gradient by dragging in the image. The starting point 
(where the mouse is pressed) and ending point (where the mouse is released) 
affect the gradient appearance, depending on the Blend tool option used. 
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Common Gradient Shapes 
 

 Linear gradient 
To shade from the starting point to the ending point in a straight line.  
 

 Radial gradient 
To shade from the starting point to the ending point in a circular pattern.  

 
Changing Gradient Colours 
 
To change the gradient colours: 
 

1. Go to the Tools Option dialog with the Blend tool selected.  
 
 

2. Click the gradient box choose from a set of gradients that ships with GIMP. 
 

  
 
The Gradient Editor dialog lets us define a new gradient by modifying a copy of 
an existing gradient. We can also add intermediate colours to a gradient, creating 
a blend between more than two colours. 
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14.4 COLOURING USING THE PAINTBRUSH 

 

The Paintbrush tool  paints the current foreground colour on an image. It 
creates soft strokes of colour. 
 
To colour using the paintbrush: 
 

1. Choose a foreground colour. 
 

2. Select the Paintbrush tool . 
 

3. Choose a brush from the Brushes dialog. 
 

 
 

4. Set tool options for mode, opacity, and so on, in the Tool Options dialog. 
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5. Click and drag in the image to paint. 
 

14.5 USING THE ERASER 

 

The Eraser tool  changes pixels to either the background colour or to 
transparent. If we are working on a background or in a layer with transparency 
locked, the pixels change to the background colour; otherwise, the pixels are 
erased to transparency.  
 

1. Select the Eraser tool . 
 

2. Set the background colour we want to apply if we are erasing in the 
background or a layer with locked transparency. 
 

3. In the Tool Options dialog, choose a required setting.  
 

 
 

4. Drag through the area we want to erase. 
 
 

14.6 FILLING WITH BUCKET FILL TOOL 

 

The Bucket Fill tool  fills adjacent pixels that are similar in colour value to the 
pixels we click.  
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1. Choose a foreground colour.  
 

2. Select the Bucket Fill tool . 
 

3. Specify whether to fill the selection with the foreground colour or with a pattern.  
 

4. Specify a blending mode and opacity for the paint. 
 

5. Enter the tolerance for the fill.  
 

 
 

6. Click the part of the image we want to fill.  
 

14.7 CLONING WITH THE CLONE TOOL 

The Clone tool  paints one part of an image over another part of the same 
image or over another part of any open document that has the same colour mode. 
We can also paint part of one layer over another layer. The Clone tool is useful 
for duplicating objects or removing a defect in an image.  
 
To use the Clone tool, we set a source point on the area we want to copy (clone) 
the pixels from and paint over another area. We can use any brush tip with the 
Clone tool, which gives us precise control over the size of the clone area. We can 
also use opacity and flow settings to control how paint will be applied to the 
cloned area.  
 
Clone Stamp Tool Options 
 
To clone with the Clone Stamp tool: 
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1. Select the Clone tool . 
 

2. Choose a brush tip and set brush options for the blending mode, opacity, and flow 
in the Tool Options bar. 
 

3. Specify how we want to align the sampled pixels and how to sample data from the 
layers in our document 
 

4. Set the sampling point by positioning the pointer in any open image and CTRL-
clicking. 
 

5. Drag over the area of the image we want to correct. 
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14.8 REVIEW EXERCISE 

 
1. Open a new document with a dimension of 300 x 300 px with a transparent 

background.  
 

2. Save the file as Flower Icon. 
 

3. Choose two colours to use for this graphic and set them up as the foreground and 
background colours in the Toolbox. Preferably one colour is lighter than the other; 
we will get better results by setting the lighter colour as the foreground colour. 
 

4. Select the Elliptical Marquee tool and ensure the Antialiasing option is turned on. 
Create an oval selection that is 180 x 50 px. Nudge the selection until it is 
approximately centered.  
 

5. Fill the selection with the foreground colour.  
 

 
 

6. Rotate the selection marquee by 60o counter-clockwise direction.  
 

 
 

7. Fill the new selection with the foreground colour.  
 

8. Repeat steps 6 - 7 once more.  
 

9. Deselect.  
 

10. Select the Fuzzy Select tool and make sure Antialiasing is enabled and Threshold 
is set to 32. Click on the coloured pixels to select the entire area. 
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11. Rotate the selection by 30o. 
 

 
 

12. Fill the selection with the background colour. 
 

 
 

13. Choose Edit > Stroke Selection to open the Stroke Selection dialog. Set the Line 
Width to 5. 
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14. Deselect. 
 

15. Open the Stroke Selection dialog again. Click on the colour swatch to open the 
colour picker. Use the eyedropper to click on the background colour. Set the line 
width to 10.  
 

 
 

16. Use the Fuzzy Select to select the center (background) colour.  
 

 
 

17. Choose Select > Shrink. In the Shrink Selection dialog, set the value to 10 and 
click OK.  
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18. Open the Stroke Selection dialog, set the Line Width to 10. We will need to click on 
the colour swatch to open the colour picker. Use the eyedropper to sample the 
lighter colour in our image. (The colour is no longer displayed as the foreground 
colour in the Tools dialog.) 
 

19.  Click Stroke.  
 

 
 

20. Deselect and save the file.  
 

 



 

LESSON 15 – 

PREPARING OUTPUTS 

 

In this section, you will learn about: 
 

 Setup 

 Previewing an image 

 Selecting output settings 

 Printing 

 Changing print orientation and size 

 Printing using defined options 

  



Lesson 15 – Preparing Outputs  ICDL Image Editing 

Page 124   © 2016 

15.1 SETUP 

 
Previewing an Image 
 
Choose File > Print and click on the Image Settings tab to display the Print 
dialog box which allows us to preview the image before printing. 
 

 
Selecting Output Settings 
 
Saving Files for the Web 
 
For web pages, we will generally want to save photos in JPEG format. JPEG is 
used more than any other format for photos on web pages. Other web formats 
include GIF, usually used for images with limited colours and PNG, a less often 
used, but flexible format. 
 
JPEG is popular because it compresses well, we can make files smaller without 
sacrificing quality. However, if we compress too much, file quality will suffer, the 
trick is to find the right balance between image quality and compression. 
 
GIMP makes this process easier through a command called Export. 
 
To save a file as a JPEG: 
 

1. Choose File > Export. 
 

2. Set the file type to JPEG image. 
 

3. Click Export. 
 

4. Adjust quality by using the Compression slider. 
 

5. Click Export. 
 
Generating Files for Print 
 
Generating files for print use is different from saving images for the web: we use 
an uncompressed file format and must be sure the file is at a high enough 
resolution (preferably 300 ppi) before we save it. It is always good to import the 
image into GIMP at the highest possible resolution to give more flexibility in the 
kinds of images we can generate. 
 
Generating files for print involves three steps: 
 

1. Setting the image resolution to 300 ppi. 
 

2. Converting the image to CMYK (if the image is going to an offset print 
vendor). 
 

3. Generating a print-friendly (compression-free or lossless) format, such as 
TIFF. 
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To generate file for print: 
 

1. Choose Image > Scale Image. 
 

2. Ensure the Resample Image option is not selected. 
 

3. Enter 300 in the Resolution text box. 
 

4. Ensure pixels/inch is selected as the units for Resolution. 
 

5. Click Scale. 
 

6. Choose File > Export. 
 

7. Set the file type to TIFF. 
 

8. Click Export. 
 
 

15.2 PRINT 

 
Changing Print Orientation and Size 
 
The Print dialog box, allows us to preview the print job and select the printer, 
number of copies, output options, and colour management options. 
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Printing Using Defined Options 
 
GIMP provides the following printing commands:  
 

 Preferences 
Displays options specific to the printer, printer drivers, and operating 
system. 
 

 Print  
Displays the Print dialog box, where we can preview the print job and 
select the printer, number of copies and output options. 
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ECDL Syllabus 
Ref ECDL Task Item Location 

1.1.1 Identify common uses of 
digital images like: web and 
print publishing, distribution 
by e-mail and mobile 
phone, home printing, 

digital photo frames. 

1.1 Common 
Uses of 
Digital 
Images 

1.1.2 Understand the terms pixel, 
resolution and identify the 
key features of a digital 
image: composed of 
discrete pixels, represented 
digitally in binary code. 

1.2 Digital 
Images and 
Pixels 

1.1.3 Understand the terms lossy, 
lossless image file 
compression. 

1.3 Copyright 

1.1.4 Understand the term 
copyright and the 
implications for image use. 
Understand the terms 
royalty-free images and 
rights-managed images. 

1.3 Copyright 

1.2.1 Understand the terms raster 
and vector graphics and 
distinguish between them. 
Identify common raster 
(jpeg, gif) and vector (svg, 
eps) formats. 

2.1 Raster and 
Vector Images 

1.2.2 Recognise proprietary 
digital image editing 
application formats: psd, 
psp, xcf, cpt. 

2.2 Proprietary 
Application 
Formats 

1.3.1 Understand the term colour 
model and recognise 
common colour models: 
RGB, HSB, CMYK, 
grayscale. 

3.1 Colour 
Models 

1.3.2 Understand the terms 
colour palette, colour depth. 

3.2 Colour Palette 
and Depth 

1.3.3 Understand the terms hue, 
saturation, colour balance. 

3.3 
Understanding 
Common Colour 
Terms 

1.3.4 Understand the terms 
contrast, brightness, 
gamma. 

3.3 
Understanding 
Common Colour 
Terms 

1.3.5 Understand the term 

transparency. 

 

 

 

 

3.3 
Understanding 
Common Colour 
Terms 

 

Ref ECDL Task Item Location 

2.1.1 Save an image from a 
digital camera to a location 
on a drive. 

4.1 Saving 
Images from a 
Digital Camera 

2.1.2 Use the print screen facility 
to capture a full screen, 
active window. 

4.2 Using the 
Print Screen 
Facility 

2.1.3 Save an image from an 
image library, web page to 
a location on a drive. 

4.3 Saving Image 
from Image 
Library 

2.1.4 Open a scanning 
application and scan an 
image: preview, set 
scanning parameters, scan, 
save. 

4.4 Scanning 
Images 

3.1.1 Open, close an image 
editing application. Open, 
close image files. 

5.2 Opening, 
Placing and 
Closing Image 
Files 

3.1.2 Create a new image file 
and set options: colour 
model, size, resolution, 
background colour. 

5.4 Creating New 
Image File 

3.1.3 Create a new image file 
from clipboard. 

5.4 Creating New 
Image File 

3.1.4 Switch between open 
image files. 

5.3 Switching 
Between Open 
Files 

3.1.5 Save an image to a location 
on adrive. Save an image 
under another name to a 
location on a drive. 

5.5 Saving 
Images 

3.1.6 Save, export an image as 

another file type like: jpeg, 
gif, tiff, png. 

5.5 Saving 
Images 

3.2.1 Set background colour, 

foreground colour. 
6.1 Foreground 
and Background 
Colours 

3.2.2 Set grid properties: units, 

horizontal spacing, vertical 

spacing, colour. 

6.2 Setting Grid 
Properties 

3.3.1 Set basic options/ 
preferences in the 
application like: 
transparency, grid settings, 
measurement units. 

7.1 Setting 
Basic Options 
and 
Preferences 

3.3.2 Use available Help 
functions. 

 

7.2 Using the 
Help Function 
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Ref ECDL Task Item Location 

3.3.3 Use magnification/zoom 
tools. 

7.3 Using 
Magnification and 
Zoom Tools 

3.3.4 Use the undo, redo 
command. Use the undo 
history. 

7.4 Performing 
Undo and Redo 
with Undo History 

3.3.5 Display, hide built-in 
toolbars, palettes, windows. 

7.5 Manipulating 
Toolbox and 
Panels 

4.1.1 Select an entire image, 
layer(s). 

8.2 Selecting an 
Entire Image or 
Layer 

4.1.2 Set selection tool 
properties: relationship 
between multiple 
selections, feathering, 
antialiasing, width, height. 

8.3 Selecting with 
Marquee and 
Lasso Tools 

8.6 Feathering 
and Anti-aliasing 

4.1.3 Select part of an image 
using selection tools: 
rectangular, elliptic, magic 
wand, magnetic lasso, 
freehand image. 

8.3 Selecting with 
Marquee and 
Lasso Tools 

4.1.4 Inverse a selection. 8.7 Inversing 
Selection 

4.1.5 Save a selection, load a 
saved selection. 

8.8 Saving and 
Loading 
Selections 

4.2.1 Change the canvas size of 
an image. 

9.1 Changing 
Image Canvas 
Size 

4.2.2 Resize an image in pixels, 
measurement units. 

9.2 Resizing 
Images 

4.2.3 Crop an image. 9.3 Cropping 
Images 

4.2.4 Copy, move image(s), 
selection within an image. 

9.4 Moving and 
Copying Image 

4.2.5 Rotate, mirror an image, 
selection within an image. 

9.5 Rotating and 
Flipping 
Selection/Image 

4.3.1 Define and understand the 
term layer. 

10.1 
Understanding 
Layers 

4.3.2 Create, copy, delete a 
layer. 

 

 

10.2 Creating, 
Copying and 
Deleting Layers 

  
 

Ref ECDL Task Item Location 

4.3.3 Set layer properties: name, 
hide, show, lock, opacity, 
blending mode. 

10.3 Setting 
Layer Properties 

4.3.4 Arrange, merge, link, flatten 
layers. 

10.2 Creating, 
Copying and 
Deleting Layers 

10.3 Setting 
Layer Properties 

10.4 Merging and 
Flattening Layers 

4.3.5 Transform layer(s): scale, 
rotate, flip, move, trim.. 

10.5 
Transforming 
Layers 

4.3.6 Convert a drawn object to a 

raster layer. 
10.6 Rasterizing 
Layers 

4.3.7 Create an animated gif from 

layers. 
10.7 Creating 
Animated GIF 
from Layers 

4.4.1 Add, edit, delete text. 11.1 Creating and 
Editing Text 

4.4.2 Copy, move text. 11.1 Creating and 
Editing Text 

4.4.3 Align text: left, centre, right, 

justified. 
11.2 Formatting 
Text 

4.4.4 Apply text formatting: font 
sizes, font types, font 
colour. 

11.2 Formatting 
Text 

4.4.5 Apply a text warp. 11.3 Applying 
Text Warp 

4.5.1 Apply artistic, distortion 
effects: pixelate, emboss, 
wind, ripple, twirl, 
desaturate.. 

12.2 Applying 
Artistic and 
Distortion Effects 

4.5.2 Apply blur effects: 
gaussian, motion.. 

12.3 Applying 
Blur Effects 

4.5.3 Apply lighting effects: 
lighting, flare. 

12.4 Applying 
Lighting Effects 

4.5.4 Apply adjustments: 
brightness-contrast, hue-
saturation, colour balance. 

12.5 Working with 
Image 
Adjustments 

4.5.5 Apply sharpen, unsharpen 
mask. 

12.6 Working with 
Sharpen and 
Unsharp Mask 

4.5.6 Apply red eye reduction. 12.7 Applying 
Red Eye 
Reduction 
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Ref ECDL Task Item Location 

5.1.1 Add a line to an image: 
straight line, free drawn 
line, curves. Set, modify line 
weight, style and colour. 

13.2 Adding Lines 
and Shapes 

5.1.2 Add a shape to an image: 
rectangle, ellipse, n-shaped 
polygon. Set, modify line, fill 
style and colour.. 

13.2 Adding Lines 
and Shapes 

5.2.1 Pick up a colour value with 
the dropper. 

14.2 Selecting 
Colour with the 
Colour Picker 
Tool 

5.2.2 Fill a portion of an image 
with the gradient tool, 
selecting 
opacity/transparency, 
radial, linear, position, 
rotation. 

14.3 Filling with 
Gradient Fill 

5.2.3 Colour a portion of an 
image with the paintbrush 
tool, selecting colour, 
shape, size.. 

14.4 Colouring 
using the 
Paintbrush 

5.2.4 Erase a portion of an image 
with the eraser tool, 
selecting its shape and 
size.. 

14.5 Using the 
Eraser 

Ref ECDL Task Item Location 

5.2.5 Fill a portion of an image 
with colour using the paint 
bucket tool. 

14.6 Filling with 
Bucket Fill Tool 

5.2.6 Clone a portion of an image 
using a clone tool, selecting 
size, opacity.. 

14.7 Cloning with 
the Clone Tool 

6.1.1 Preview an image. 15.1 Setup 

6.1.2 Select appropriate colour 
depth, resolution, image 
size, graphic format for 
web, screen, print use. 

15.1 Setup 

6.2.1 Change print output 
orientation: portrait, 
landscape. Change paper 
size. 

15.2 Print 

6.2.2 Print an image to an 
installed printer using 
defined options, default 
settings. 

15.2 Print 

 





 

 

 

Congratulations! You have reached the end of the ECDL Image Editing book. You have learned 

about the key skills relating to Gimp software, including: 

 Understand the main concepts of using digital images; understand graphic format options 

and colour concepts.  

 Open an existing image; save an image in different formats; set image file options. 

 Use built-in options, such as displaying toolbars, palettes, too enhance productivity.  

 Capture and save an image; use various selection tools; manipulate images.  

 Create and use layers; work with text; use effects and filters; use drawing and painting 

tools.  

 Prepare images for printing or publishing.  

 

Having reached this stage of your learning, you should now be ready to undertake ECDL certified 

testing. For further information on taking this test, please contact your ECDL test centre.  

  



 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


